返回顶部
开启左侧

[通达信] 亮剑成交量(通达信公式 副图 源码 测试图)

[复制链接]
股票大数据 首发新人 显示全部楼层 发表于 2021-10-8 17:18:08 |阅读模式 打印 上一主题 下一主题
公式的参数以下:
202011718275791689.png
公式的源码:

VOLUME:VOL,VOLSTICK;
MA4:MA(VOLUME,M1);
MA50:MA(VOLUME,M2);
MA120:MA(VOLUME,M3);
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交量:VOL,POINTDOT,COLORYELLOW;
购盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
成交量比%:购盘/VOL*100,COLORWHITE,NODRAW;
VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
赢利盘: WINNER(CLOSE)*100;
VAR33:=SMA(VAR22,3,1);
VAR44:=SMA(VAR33,9,1);
VAR55:=3*VAR33-2*VAR44;
VAR66:=VOL;
量比: VOL/MA(VOL,5);
斩贴: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
换脚: VOL/CAPITAL*100;
VAR77:=SUM(换脚,30);
VAR88:=LLV(INDEXL,5);
VAR99:=HHV(INDEXH,5);
VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);
VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);
VARCC:=MA(VARBB,30);
VARDD:=EMA(赢利盘,4);
本盘亿股: CAPITAL/1000000,;
VARF:=(斩贴>VARDD AND 角度<-30 AND 斩贴>3);
CROSS(VARBB,VARCC) AND VARCC<29;
CROSS(VARCC,VARBB) AND VARCC>58;
STICKLINE(VOL AND VAR33>VAR44,0,VOL,2.5,1),COLORRED;
STICKLINE(VOL AND VAR33<=VAR44,0,VOL,2.5,1),COLORCYAN;
STICKLINE(购盘>0,0,购盘,2,0),COLORRED;
202011718284242361.png


请点击此处下载

查看状态:需购买或无权限

您的用户组是:游客

文件名称:亮剑成交量.tn6 
下载次数:1  文件大小:7.77 KB 
下载权限: 不限 [积分规则] [免费赚首币]









上一篇:强势黄金眼主图优化(通达信公式 主图 测试图)
下一篇:分时均线升级版,自动适应,日K线中标注出当日的分时均价

精彩评论2

sanwa97 黄金首粉 显示全部楼层 发表于 2021-10-9 22:31:00
楼主辛苦了,谢谢首发之家!!
sanwa97 黄金首粉 显示全部楼层 发表于 2021-10-9 22:31:40
楼主辛苦了,谢谢首发之家!!
您需要登录后才可以回帖 登录 | 立即注册 用百度帐号登录

本版积分规则

首发之家社区成立于2011年3月,内容涉及3C家电、数码生活智能电视,股票软件,4K,体育,软件,教育,游戏等资源指标公式论坛。
  • 官方手机版

  • 抖音号

  • 商务合作

  • Powered by Discuz! X3.4 | Copyright © 2011-2021, Tencent Cloud. | 首发之家社区
  • |网站地图 | mp4d@qq.com|小黑屋|手机版|